NAM - problem z aktualizacją firmware

Od kilku dni mój NAM pokazywał stałą wartość PM10 i PM2.5. Byłem pewny, że padł SDS011. Dzisiaj przyszedł zamówiony nowy SDS011 i po podłączeniu ten sam problem. No to wymiana Wemosa i jest ok :grinning: Tak więc coś się podziało z Wemosem i pokazywał cały czas jednakową wartość.

Przy okazji wymiany Wemosa należało wgrać na niego firmware. Zrobiłem to narzędziem nam-flashing-tool, gdyż linki do binarki na stronie Nettigo Air Monior - NAMF Instalacja nie działają.
Po skonfigurowaniu NAM do własnej sieci Wi-Fi mam firmware NAMF-2019-024. Próba aktualizacji do wersji 2020 poprzez http://ip_esp/forceUpdate nie przynosi żadnego efektu.
Proszę o informację, w jaki sposób można obecnie zaktualizować firmware do gałęzi 2020?

Pozdrawiam
Robert Błaszczak

Sam sobie odpowiem. Problem występuje po automatycznej aktualizacji firmware 2020-37 do 2020-38. Taki problem też zaobserwowałem najnowszej becie.
Odnośnie aktualizacji do gałęzi 2020 to znalazłem *.bin na GitHub.

A to ciekawostka, bo jeden z moich NAM–ów, również pokazuje stałą wartość PM z SDS i uznałem, że to SDS i tak czeka na wymianę, a tu się może okazać, że to jednak nie jego wina. :thinking:

Też tak myślałem i nawet kupiłem w Nettigo SDS011. Jednak problemem okazał się firmware. W tej chwili mam wersję 2020-37 i wyłączoną opcję automatycznej aktualizacji firmware i na tej wersji jest ok.
Mój NAM: https://robert.aqi.eco

Firmware NAMF-2020-40rc2 z kanału beta naprawia ten problem.

image

Wersja 38 namieszała w budowie pliku „data.json”, pozamieniana kolejność wysyłania danych (ważne przy własnej obsłudze czujnika - u mnie przez NodeRed - długo nie mogłem znaleźć przyczyny błędów)